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In functional terms, a reference manager is a program that allows you to collect, organize, and cite reference
materials (e.g., books, journal articles, websites). It has become an invaluable tool for anyone engaged
in modern academic writing.
Through my career I’ve used a variety of reference managers, and their
functionality is an integral part of my work flow which involves reading academic material, collaborating
with other authors, and writing across a variety of platforms such as LaTeX, Authorea, and Libre Office.

Selection Criteria
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Based on this experience and my preference for open-source software, I’ve come to place high importance on
the following functionality/characteristics when selecting a reference manager.
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Portability so it works across a variety of writing platforms and operating systems
Local and cloud storage for working off-line and synchronization across devices
Multiple import options that include adding items by object identifier, RIS, and BibTeX
Shared libraries for collaborating with other writers
Cross-folder assignment that allows references to be included in multiple folders
Document upload for attaching pertinent files and notes to references
Open source code so the community can audit the program and develop additional functionality
Good faith operations that exclude collecting and selling the personal information of users
Reasonable price preferably a freemium price strategy that allows paid or free versions
Intuitiveness because the software should work for the user, not the other way around

Most of the major reference managers check the boxes on 1-6 quite well, although some do particular tasks
better than others. It’s the addition of 7-10 that makes Zotero an outstanding reference manager from my
perspective. Zotero is a community developed, open-source platform that offers both free and paid levels.
The free level comes with all the functionality of the paid, just with restricted cloud storage. Your reference
collections and user information are as private as you choose them to be. As a professional platform, some
choose to make their information publicly visible, but that’s up to you. Regardless, the platform does not
scrape and sell your personal information. The interface is quite intuitive for a platform with extensive
functionality. And because the code is open source, you can find a wide variety of add-ons to customize the
way Zotero works for you.

Putting Zotero to Work
This section covers the basic functions of the Zotero reference manager. This assumes that you have downloaded a desktop interface and created a free account. I suggest selecting the Standard installation when
prompted. Once you have created an account, be sure to sign in to your desktop interface so your entries
sync to the cloud. Desktop Zotero will function just fine without being logged in; but you risk data loss
in the event of a crash. Syncing can be done by opening your desktop interface, navigating to Edit ->
Preferences -> Sync, and logging in to your account. While downloading the desktop, it’s also useful
to install the Zotero Connector onto your web browser. This will be necessary for automatically importing
references, a process I will describe later.

Integrating Zotero into MS Word or Libre Writer
The ultimate function of a reference manager is to add citations to your papers. The most straightforward
way to do this is by integrating Zotero with your preferred writing editor. If you are prompted to do
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so during installation, then accept the integration request. If not prompted, open Zotero and navigate
to Tools -> Add-ons. You will see something similar to Fig 1.
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Figure 1: Enable Zotero Integration
Enable integration for any installed writing editor with which you intend to use Zotero. You will be prompted
to restart Zotero at this point. Once you have done so, you will see something similar to this the next time
you open MS Word (Fig. 2) or Libre Writer (Fig. 3).

Figure 2: Integration in MS Word
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Figure 3: Integration in Libre Writer
Once you’ve begun a document, open Zotero Document Preferences from the editor’s toolbar and select
your preferred citation style as pictured in Fig. 4. Libre Writer users will find similar icons to those pictured
here.
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Figure 4: Setting Document Preferences
Now you’ve written some content and need to add a citation. Be sure your Zotero desktop is open (if not you
will be prompted to do so). Simply place your cursor where you want the citation added, select Add/Edit
Citation from your writing editor’s toolbar, and start typing the name of the author, relevant keywords,
or name of the reference. You will notice that {Citation} will be added in place of your cursor to indicate
the selected location in the text. A drop down list will appear with choices. Select the desired reference
and it will appear in the Zotero bar as shown in Fig. 5. Libre Writer users will find similar icons to those
pictured here.
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Figure 5: Adding a Single Citation
If you need to add additional citations for the same content, simply start typing in the bar again and select
the additional citation(s) as shown in Fig 6. Don’t worry about the order of your citations, Zotero will
handle that for you based on the citation style you selected when setting up Document Preferences.
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Figure 6: Adding Multiple Citations
Once you have all the desired citations added, simply hit Return/Enter and your citations will be included
in the text as shown in Fig 7.

Figure 7: Citations in Text
Continue this process as you write. Citations can be added or deleted and Zotero will keep track of them
as you go. Once the document is complete, create a reference section and select Add/Edit Bibliography
from the Zotero options in the editor’s toolbar. A reference list will be created for each (Fig. 8) based on
the citation style you selected when setting up Document Preferences. Libre Writer users will find similar
icons to those pictured here.
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Figure 8: Reference Section
Once you’ve created a reference list (i.e., bibliography) the entries can be edited manually, but it’s better
practice to correct any mistakes within Zotero and select Refresh. Another option is to select Add/Edit
Bibliography which will now open in editor mode to make specific changes to your extant entries.
Of course, you first need to have references in Zotero before adding them to your document. The following
section will cover a few options for accomplishing that.

Adding References to Zotero
There are a variety of way to add items into Zotero. I will cover three common ways here: manual entry,
entry with identifier, and RIS import.
A word of caution is appropriate here before moving into the mechanics of this process. Zotero, or any
reference manager for that matter, is not a replacement for knowing the citation style and writing conventions
of your field. You will occasionally need to edit the references generated by Zotero, and will certainly need
to know what information is required (and what can be omitted) when creating an entry in Zotero. This
requires that you understand how to reference common sources such as books, journal articles, conference
proceedings, and websites. It’s easier to build a well-curated corpus of references from the beginning than
it is to correct previous mistakes.
1. Manual Entry. Manual entry is the most cumbersome way of creating a reference, but sometimes other
options are not available. Simply select the green + icon and choose the appropriate reference type from
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the drop down as show in Fig. 9. Most common reference types are listed here; and Zotero will provide
your most frequently used types at the top of this list.
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Figure 9: Manual Entry
Selecting the reference type will open a window where you can enter pertinent information about the source
as pictured in Fig. 10. This is where knowing what is required for a given reference type and what is
not becomes very important. Here you can also attach notes, add tags, and associate the entry with other
references if desired.
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Figure 10: Adding Reference Information
Although I’ve praised Zotero for it’s intuitiveness, one of its less intuitive features, and a regular point of
confusion for newer users, is how to add editors (the human type) to an entry - necessary information for
a book section or edited book. The drop down menu does contain a Book Section option, but this gives
no obvious choice for adding editors. The trick here is to add the editor(s) as you would with a regular
author, then select the small arrow to the left of Author. This will open a menu that allows you to set the
individual’s role (e.g., Editor, Series Editor, Contributor). Once this is done, Zotero will take this cue to
work out what type of reference it’s dealing with when formatting your citation for your reference section.
2. Entry with Identifier. An easier way to add an item is to use the integrated Zotero database. If you
have an object identifier (e.g., DOI, ISSN, PMID), you can enter it as pictured in Fig. 11.
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Figure 11: Entry with an Object Identifier
This method often provides the most robust information about the reference and will sometimes even attach
a PDF of the reference to the entry. If a PDF is not automatically downloaded and you have a copy, you can
attach it by selecting the reference, clicking the Add Attachment (paperclip) icon, and selecting the desired
attachment type. I tend to use the Attach a Stored Copy of the File option. Once the reference is
added you can access it by clicking on the small arrow to the left of the entry as pictured in Fig. 12. Notes
added to the entry can be accessed in the same way.

Figure 12: Accessing Attached Files and Notes
3. RIS Import. Often references are accessed through an academic database (e.g., JSTOR, Academic
Search Premier, Sociological Abstracts) or through Google Scholar. A third way to add an entry into Zotero
is to select the RIS import from the database while your Zotero desktop is opened. If you have completed the
earlier step of downloading the Zotero Connector to your browser, this will automatically add the item into
Zotero. The exact process for this differers across academic databases, so just look for the option to import
using an RIS file. In Google Scholar this is not an option, so simply select the " (single quotation mark) in
the Google window, then choose the RefMan import option as shown in Fig. 13. This will accomplish the
11
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same function as importing with RIS.

Figure 13: RefMan Option in Google Scholar

Tailoring Zotero
Everyone has their own preferred way to set-up and organize Zotero, but there are some basic things everyone
can do to get started.
1. Behind the Curtain. First, set your Export and Cite preferences. Navigate to Edit -> Preferences
-> Export and select a Default Format from the drop down as shown in Fig. 14. This function allows
you to export your library as a .bib file that can be used with other writing platforms such as LaTeX and
Authorea. I’ll discuss one use case for the .bib file export later. Here you can also select your preferred
language for the platform.
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Figure 14: Set Export Preferences
Next, navigate to Cite and select your default Style Manager (i.e., citation style) as shown in Fig. 15. This
directs Zotero how to cite references when you add them in a document.

Figure 15: Set Cite Preferences
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If you have intentions on becoming a power user, you’ll want to learn at least some of the keyboard shortcuts. The defaults can be found, and customized if desired, by navigating to Advanced -> Shortcuts as
show in Fig. 16.

Figure 16: Keyboard Shortcuts
2. Organizing and Sharing. Zotero begins with a default My Library. All your entries can be added
here, but it’s good practice to add folders (called Collections in Zotero) within My Library otherwise you
will end up with a mass of unorganized references to sift through. Folders can be added by clicking on the
New Collection icon (smaller folder) in the Zotero toolbar as shown in Fig. 17. References can be added
to a collection by simply dragging and dropping them in the desired location.

Figure 17: New Collection Icon
Determining how you will organize your collections is a non-trivial decision. The good news is that Zotero
allows you to assign references to multiple folders simultaneously. So a journal that belongs in the “K-12 prep” collection and the “FIELD ex-function” collection can be assigned to both by simply dragging the
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entry into the desired folder. Any changes you make to a reference in one collection will be made across all
collections; so you don’t need to worry about version control issues. References can be moved to the trash
altogether, or just removed from a given collection but kept within Zotero. Any references not assigned to
a collection will be found in the Unfiled Items folder.
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Items in your My Library and subordinate collections are visible only to you. However, the platform also
supports group libraries that can be shared with other Zotero users. To create a shared Library, select New
Group from the drop down icon (larger folder) from Fig. 17 above. This will take you to the Zotero website
as shown in Fig 18. You will need to log in using your credentials and make some selections about the
public visibility of the group.

Figure 18: Creating a Group Library Online
Once created, your group library will appear in your collections area of Zotero as shown in Fig. 19. Items
can be added to the group libraries by dragging them into the folder just as you would with any other
collection. Similarly, subordinate collections can be made within a group folder just as you would within
your primary library. These will now be visible to all group members.
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Figure 19: Group Library in Desktop

Using Zotero in Authorea
Authorea is an online platform designed for academic writing and publishing. For academics and students,
it’s a particularly good alternative to collaborative writing platforms such as Google Docs due to its robust
citing functionality and myriad other features beyond the scope of this post.
I do the majority of my
writing in Authorea and host the Alternative Hypothesis blog on the site. Here I will briefly cover the
process for integrating Zotero into Authorea and accessing references within the platform.
First, I should be more specific. You do not actually integrate Zotero into Authorea as you do with MS
Word or Libre Writer; rather, you attach an exported library file to an Authorea document so you are able
to cite your references within that document. If you’re not especially tech savvy, don’t worry; this is easier
than it sounds. Begin by exporting your Zotero library as a .bib file. To do this, open desktop Zotero,
select the My Library folder, then navigate to File -> Export Library.
You will see a number of
export types in a drop down menu. Select BibTeX from this list and leave Character Encoding at the
default Unicode (UTF-8) as shown in Fig. 20. I tend to leave the Translator Options unchecked; but
if you are writing with a citation style that uses journal abbreviations, you will want to check this option
(note: APA 6th does not use abbreviations).
Name your newly created .bib file and select a location to
save it.
Although Authorea will accept file names with spaces, many programs do not. It’s good practice to always
name files with some form of connector between words rather than spaces (e.g., zotero-lib-full.bib or zotero my-library.bib).
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Figure 20: Exporting My Library
Now create a document in Authorea or open an existing one. Within the document, navigate to Document
-> Data -> Bibliography. Here you can upload the .bib file you created in Zotero through drag and
drop or by selecting it as shown in Fig. 21. Once your .bib file is uploaded, click on Data again for an
option to navigate back to the document view. Your reference file is now attached and ready for use within
the document.

Figure 21: Uploading the Reference File
Authorea comes preloaded with the Pubmed and CrossRef databases. References can be searched for in
these and added to your document. Now that you have uploaded your Zotero library, it will appear alongside
these preloaded databases as Local. Citing from your imported Zotero library within an Authorea document
is rather straightforward. Place the cursor where you wish to insert the citation, click Cite in the toolbar,
select the radio button labeled Local, and begin typing search terms in the search bar as shown in Fig.
22. Terms can be the name of the author(s), keywords, or title of the reference. A list of references will
begin to populate.
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Figure 22: Insert a Reference
Simply click Add next to the desired reference. You will then be given the option to Change Citation
Text which allows you to select from a variety of in-text citation options (e.g., suppress author, remove
parentheses) or simply to Cite and Close. Once added, Authorea will automatically make a reference list
at the end of your working document and update the list each time a new citation is added. References
will appear in a generic format in the reference section. Note that these will appear in a generic Authorea
style, not formatted to a particular citation style.
At some point, you may wish to export your document. Authorea gives you the ability to export as a PDF,
LaTeX, or MS Word document as shown in Fig 23. Simply navigate to Export and select your preferred
document type from the drop down menu.

Figure 23: Exporting a Document
You have the ability to change the citation style used when exporting from Authorea by navigating to Export
-> Export Options, then selecting your preferred style as shown in Fig. 24. Note that the references in
your working document will not reflect this style choice. As mentioned above, they will retain a generic
18
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Authorea style. Formatting occurs only when you export the document, so be sure to check the reference
section of the export to ensure it reflects the style you specified.

Figure 24: Select Export Options

Closing Thoughts
This post introduces just the basic functions of the platform and only scratches the surface of what Zotero
can do. There are a robust community of platform users who post tutorials such as this one, how-to videos,
as well as an official Zotero blog where you can learn more about its functionality. Once you’ve spent some
time on the platform, I encourage you to expand your expertise with these resources.
Happy writing!
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